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What is PabloDraw

PabloDraw is what is called an ‘Ansi Editor’.  It can be used to create and edit Ansi coloured text files.  Nowadays, these files usually are drawings of fictional characters, or a logo of some sort to promote a telnet board or group.

What is Ansi?  Ansi is essentially coloured text, which is best represented in a mono space font, such as used in a DOS, or command line.  

Instead of going into a long schpeal about the history of Ansi, I will just say that Ansi coloured text is used on the internet today, by what is known as telnet boards.  These boards use the same technology to display information on the screen as the old Bulletin Board Systems (better known as BBS’) that used to be very prevalent back in the late 80’s and 90’s.

System requirements

Minimum requirements

· Windows 98se/Me/NT/2K/XP, or Windows 98 with Accessibility update

· DirectX 7.0 or greater (for full-screen mode)

Using PabloDraw

PabloDraw is best used with the keyboard.  It has been designed to closely match the same type of drawing programs that were used in DOS in the 90’s.  However, there are many Windows-like features that give it that extra ‘kick’ into the next millennium, such as the snazzy GUI interface, and multi-user capabilities.

Your first drawing

PabloDraw’s default configuration is set up so that you can start drawing very quickly.  There should be a blinking ‘Cursor’ in the main screen when you start it up, which you can move with the cursor keys, home/end/pgup/pgdn, etc. 

You can type in the screen just like a normal text editor.  To make drawing easier, there is the following toolbar at the bottom of the screen:
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This depicts the current quick-characters that you can use by pressing the F1-F12 keys on the keyboard.  These default characters are usually used for shading and shaping objects on the screen.  You can change these by pressing Alt+F1-F12, and Ctrl+F1-F12.  The default (shown) is Alt+F6.  

Note: 
In Windows 98, and ME, you must press Shift+F6 to get back to the default character set, since the operating system does not allow applications to use this system-defined key.  In Windows NT, 2000, and XP Alt+F6 should work fine.

In Ansi, there are also colours.  You can use the background/foreground colours in combination with the characters that you put on the canvas to produce shading effects to detail your drawing.  You can change the current colour by using the mouse with the colour toolbar shown below:
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You can change the foreground colour by clicking the left mouse button on one of the colours, or press Ctrl+Up/Down.  To change the background colour, use the right mouse button, or press Ctrl+Left/Right.  You can also press Ctrl+1-8, or Alt+1-8 to quickly change to a colour, and again to change it’s intensity from normal to bright.

It is often useful when you are making a large drawing to use the preview window to ensure your drawing is proportional.  To show the preview window, select View->Preview Window, or press Alt+V.

Drawing with others

One good way to learn how to draw real good, real fast is to watch someone else draw!  And with PabloDraw, you can do this without driving 10,000 km to where your Ansi Idol lives (or across town to your friends house).  This is called Multi-User Drawing, and PabloDraw allows a virtually unlimited number of users to connect to one server, all drawing at the same time.  

There are two parts to drawing with a friend.  One of you must be a ‘server’, and one a ‘client’.  If you want more people to join, they can just connect to the same server.  To start a server, go to Tools->Start Server.  It will give you the following dialog:
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Here you get to choose an ‘Alias’ for yourself to identify you when you are chatting, and on the User List.  The Port is a communications port to use through the Internet to connect to.  When someone connects to your server, they must specify the same port you have chosen to use.  The default is 700.

When you are connecting to a server, you get the following:
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Here you get the same options, however you must also specify the IP address of the machine that is running the server.  The Port number you choose must match the same port number that the server was started with.

Note:
When you are connected to a server, everything you do will be shown to all other users connected to that server.  So if you clear the screen, then it will clear the screen of everyone connected to the same server.  This also applies for loading, block cut/copy/paste/fill, etc.

Keyboard reference

Global keys

	Key
	Description

	Arrow Keys
	Move the cursor up/down/left/right in the canvas

	Home/End
	Move the cursor to the beginning/end of the screen, and again to the beginning/end of the canvas

	PageUp/PageDown
	Move the cursor up or down one screen of the canvas

	Ctrl+PageUp/
Ctrl+PageDown
	Move the cursor to the first row or last row of the canvas

	Alt+L
	Load/Open a file

	Alt+S
	Save to a new file (with prompt)

	Ctrl+S
	Save current file (without prompt)

	Alt+C
	Clears the canvas

	Alt+B
or Shift+Arrows
	Select a block, puts canvas in block mode

	Alt+F1-F10
	Select character sets 1 – 10

	Ctrl+F1-F10
	Select character sets 11 – 20

	F1 – F12
	Draw a character from the currently selected character set

	Ctrl+Right/Left
	Change the background colour

	Ctrl+Up/Down
	Change the foreground colour

	Alt+U
	Use the colour under the current cursor position

	Alt+M
	Switch from 8x16 font to 8x8 font

	Ins
	Toggles Insert mode

	Alt+Left/Right
	Insert/Delete a column at the current cursor position

	Alt+Down/Up
or Alt+I/Y
	Insert/Delete a row at the current cursor position

	Ctrl+V
or Shift+Ins
	Pastes the data on the clipboard starting at the current cursor position

	Ctrl+Z or Alt+R
	Undo previous action

	Ctrl+Y
	Redo previous action


Keys in block mode

Block mode is the mode in which you are selecting an area of the canvas.  In this mode, you cannot draw to the canvas and have only the following functions:

	Key
	Description

	B
	Brings up the block menu

	D
	Deletes the currently selected block, shifting everything right of the block into the deleted area

	E
	Erases the currently selected block without changing any other data

	F
or Ctrl+F
	Shows pop-up menu of fill options; Character, Attribute, Back, Fore, and Both.

	Ctrl+X
or Shift+Del
	Cut the current block selection into the clipboard and exits block mode

	Ctrl+C
or Ctrl+Ins
	Copies the current block selection into the clipboard and exits block mode

	C
	Copies the selection into the buffer and goes into Paste Mode

	M
	Moves the selection into the buffer and goes into Paste Mode

	
	

	Esc
	Escapes out of block mode without making any changes


Keys in paste mode

Paste Mode is where you have selected a block and chose to Copy it or Move it

	Key
	Description

	Arrow Keys
	Move the block around

	X
	Flips the block in the buffer horizontally

	Y
	Flips the block in the buffer vertically

	R
	Rotates the block in the buffer clockwise

	U
	Toggles between showing the block in the buffer on top of the canvas, or behind the canvas.

	T
	Toggles between showing the background picture through the empty parts of the block

	S
	Stamps the block in the current position

	Enter
	Pastes the block in the current position and exits paste mode

	Esc
	Exits out of paste mode without making any changes


Contact

Pablo Draw is most likely the only Ansi editor out there for windows and has multi-user capabilities.  This hopefully will allow the Ansi/Ascii scene rise to new levels of co-operative artwork and collaboration (and to give it a good swift kick in the ass).  

Internet contact

You can get more information, ask questions, submit bugs, or get the latest version of PabloDraw at:

http://pablo.etoxn.ca
Or email Curtis Wensley aka Eto at eto@shaw.ca

About the author

Eto has been part of the ANSI/ASCII community since 1995, and part of the scene in general since 1992.  
Back in the day, he was in groups such as PiXEL, Sonic Equinox, and Mistigris.  For these groups, he did many graphical application generators, demos/loaders, etc.  

The latest incarnation of PabloDraw (for windows), started out as a prototype in 1999, but has only been in production since mid 2001.  He only works on it in his spare time, and does it mostly for fun (and glory).  

About PabloDraw

PabloDraw started out as a DOS Ansi editor that was pretty basic.  The original version was coded by Minus of Mistigris.  However, he had fallen off the face of the earth shortly after building the initial version.
Cthulu (of Mistigris) then asked Eto to ‘update’ Pablo a little to fix some annoying bugs.  That is where things really took off.  Eto decided not only to update it, but add significant functionality to make it one of the most comprehensive Ansi editors for dos to date.  The entire dos application was re-written from the ground up, giving users complete control over it’s configuration.

In 1998, Eto decided to try his hand with a windows version of PabloDraw.  This version was written in VC++ and had an early prototype of the multi-user capabilities.  With the scene declining and no real interest by artists (Pablo sucks! They said), Eto decided to stop working on Pablo (besides, he had just started working on a huge project at work that took up all his spare time!).
Then, 3 years later in 2001, Eto was bored.  He went on irc and flogged his 1998 prototype around a little to see if there’s any interest.  And there was!  Major work went into adding basic drawing functionality and hence PabloDraw for windows was born.

PabloDraw continues to be the only actively supported ansi editor in the scene today, and gets over 1000 downloads per release in a 6 month period.

Change log

Ideas for future versions

These are some things that I’m thinking of implementing in future versions (in no particular order).  If any of these are of special interest to you, send me an email (see the ‘Contact’ section)

NOTE!!  The current MFC-based code is no longer being developed.  A new, .NET version is now under development.  Okay.  So I lied.

Ansimation support using a frame-based interface (.NET)
SAUCE support

XBIN/ADF/IDF support, allowing changing of fonts and palette

Showing the cursor of each user connected to the server on the canvas, with user-definable colours.

Ansi viewing mode that loads up a ZIP directly, and displays thumbnails for each file (for viewing packs) (.NET)
Mouse-driven Ansi drawing (like a paint program) (.NET)
Multi-user RIP editing (Vector Formats) (.NET)
Multi-user Hi-resolution editing (Raster Formats – BMP/JPG/PNG) (.NET)
DOS simulated font – a font for windowed mode which simulates the aspect & characteristics of the DOS video mode.  (.NET)
2.0.8.69 – July 4, 2004
Added option to toggle use of SHIFT+Arrows/PGDN/PGUP/etc for selecting a block for all youz ascii peeps out there (Tools->Options->Use Shift+Arrows for selection).  You can still select a block using alt+b, or the mouse.

Added option to toggle the blinking cursor cuz for some, it’s annoying I guess! (Tools->Options->Blinking Cursor)

Bug: Fixed problem with miscellaneous characters showing as you draw, cut/paste, etc. in both single and multiuser modes.

Did MASSIVE re-working of the multiuser code.  This included a) sending a tag & size of each packet sent/recieved, b) making the client & server both handle invalid clients connecting to the server, etc. c) re-working the client connect sequence so that packets aren't sent even though the connection hasn't been fully established yet, d) changed the client to receive data in a separate thread, and e) other miscellaneous fixes.  This should make the server much more stable, and able to handle many more clients.  Also, the responsiveness on the client should be improved considerably.  As spinsane put it, it's like BUTTER. (:

Bug: Fixed block rotate when you do not move/copy first (select, then press 'b', then 'r').  It didn’t properly clear out the old data, nor setup the undo buffers. (reported by Bhaal)

Bug: Fixed crash when doing first copy/paste after loading pablo.  Uninitialized variable (reported by Bhaal)

Added 'Notepad Mode' for those of you that are used to a white background. Kinda useless (can just select, then (b)lock, (f)ill, (a)ttribute), but nice nonetheless (requested by spinsane).

Added a dotted line to the window to signify the width of the canvas (requested by Ohseven and cat-dog)

Added file backups.  If the file exists, it will be renamed to the backup file.  If multiple backups are selected, then it will append the backup number to the file name (Tools->Options->Enable Backups and Tools->Options->Multiple Backups).

When scrolling using the mouse wheel while pasting a block, the block will update based on the new scroll position.

Added Mini/Classic mode, which makes the color/character/status bars to be more like the dos ansi editors (uses full-screen mode controls)

Full-screen mode will now work with 640x480 if 640x400 isn't supported by the video card.  Also tests for 24-bit modes as well as 16-bit modes.  This should make ANY video card work with full-screen!

Main window will now remember it's size from the last time it was run

Will now remember if you were in full screen when launching (for people that like full-screen only)

Fixed multi-user chat history window to work with wine under linux (everything should now work in wine, even hosting a server!).

Added CTRL+0-7 and ALT+0-7 keys to quickly set the foreground or background colors.  ALT+0-7 is for background, CTRL+0-7 is for foreground.  Pressing the first time will set the color.  Press again, and it will set it to the light color. E.g. Press CTRL+7 will set the foreground to gray.  Press CTRL+7 again and it will set the foreground to white.  This was originally in pablo-dos. 

Can now set the width of the canvas without having to load a .BIN to do it.  Just go to file->Set Canvas Width

Increased most recently used file list to 10 items instead of just 4

Bug: When changing fonts (80x50, 80x25, and Amiga), it will now update the preview pane as well.

Bug: Fixed crash with the first block paste operation after starting pablo

Bug: Some mice always post a mouse move event, causing the cursor to move to the mouse position when copying/moving a block.  It is now avoided by only moving to the mouse cursor when the character position of the mouse changes, instead of the pixel position (same as what was done for fullscreen mode in 44).

Updated to a new high-color PabloDraw icon

Added ESCAPE/Alt+A color selection menu.  Supports using arrows to select foreground/background, and also you can just type the numeric value for the colors, so the functionality matches other ansi editors and what people are typically used to doing.

Added option to turn off usage of standard windows keys (Tools->Options->Use Windows Keys).  This disables keys such as CTRL+C, CTRL+V, etc so that they can be used like they are in dos apps (e.g. ctrl+v inserts a mini block character). (Requested by abstrakt). 

Added ALT+R and SHIFT+ALT+R to undo/redo respectively.  This is because CTRL+Z/CTRL+Y are windows keys and can now be turned off.  This is the alternative, which matches aciddraw and other dos editors for undo (although pablo has multiple undo so a redo key is necessary) 

Added moving by TAB/SHIFT+TAB.  Turn on Tools->Options->Keyboard->Use Tabs.  To switch between chat window and drawing surface, press CTRL+TAB when this is on (requested by abstrakt).

Made the cursor show always when moving.  This will make it easier to follow the cursor when using the arrow keys.  When you stop moving the cursor, it will continue to blink (if blinking cursor is turned on).

Made the cursor show as an underscore instead of a full block.  When insert mode is on, it'll show as a half-block.  This emulates dos much better, and makes the blinking cursor much less annoying.  When blinking cursor is turned off, it will still be a full block, however.

Bug: Fixed deleting a block when it included the last column on the canvas (Reported by goatboy, smoke)

Added more default extensions to the loading formats (*.diz, *.mem, *.nfo, *.ice, *.tnt) so other typical file types will show up by default (suggested by nstage)

Bug: Fixed pasting under or transparent blocks when in multi-user mode (reported by svg, nstage, etc)

2.0.7.44 – December 28, 2003

Added ITP-Draw compatibility mode when selecting colors (ctrl+arrows are switched)

Bug: When saving ansi, PabloDraw will now set the start color so it loads properly in aciddraw, and some viewers

Bug: Saving to binary skipped the last line

Bug: More general fixes to the multi-user communications to be less bug-prone

When bringing the PabloDraw window back into the foreground, it will set the focus to the last focused control (so if you were in the chat window before, it will when you alt+tab back to Pablo).

When someone loads a file or clears the screen in multi-user mode, pressing SAVE will not overwrite your old file.

Added Amiga font support (View->Amiga font)

Added block flip/rotate character mappings (so the image will remain intact when flipping/rotating)

Bug: Fixed full-screen mouse cursor.  It sometimes re-positioned the cursor even if not moving the mouse 

2.0.6.35 – August 16, 2003

Can now hold down shift and use arrows/paging/home/end/return/backspace without any funky characters showing up (Reported by: fille)

Made multi-user drawing faster by compressing the data transferred.  Currently using the ANSI encoding to compress before transferring.

Added Alt+U function to pick up colour under the cursor

Added Block Character/Attribute/Back/Fore fills

Added Block Delete/Erase/Flip/Rotate

Added Block Copy/Paste between windows

Added Preview Window

Now supports copy/paste of blocks similar to dos drawing apps, using ‘C’ to copy or ‘M’ to move. (Ctrl+X/C/V work the same as windows apps still)

Added insert mode so when you type it will move the rest of the line (Ins)

Added a names list when connected to a server

Made TAB switch between drawing and the chat window.  In full-screen it will hide the chat window to maximize drawing space

Added 200 level UNDO/REDO (Alt+R or Ctrl+Z/Ctrl+Y).  In multi-user mode, the undo buffer will be shared among all users for now, to avoid complications of having to modify each local undo history based on what changes other people make.

Fixed load/save dialog not showing up in Win9x

Added iCE colours & blinking text.  In blink mode (non-iCE) the background will only cycle the first 8 colours

Fixed loading BIN files with larger widths when connected to a server

Added Full-Screen mode (Alt+Enter) so that you can draw with the same aspect ratio as DOS.  (requires DirectX 7, and 640x400x16 mode support)

Added Alt+C to clear the canvas

Can now load unix-type ansi/ascii files

Switched to an SDI interface (only one ansi can be loaded per instance of pablodraw) to simplify the interface

Fixed many, MANY multi-user bugs to eliminate any crashing/freezing

Now safely disconnects a user if the other end has crashed or disconnected unexpectedly

External DLL’s are now no longer required (except DirectX)

Created User Guide document (hmm.. overkill? Probably.. but it was fun)

The chat window will now auto-scroll in 9x/NT

Mouse now works the same as dos drawing apps when in full-screen mode

Can now Cut ‘n Paste between different instances of PabloDraw using the windows clipboard (use Ctrl+C, Ctrl+V)

2.0.5 – February 10, 2002

Added CHAT interface - Win9x/NT users won't have auto scrolling for now.

Added ASCII/BIN saving and loading (including file associations)

Fixed crash when starting up pablo

Added rudimentary block functions (cut, copy, paste)  Acts like normal windows programs for now

Fixed some other small bugs

2.0.3 – November 7, 2001

Added Colour Toolbar (switch with Ctrl+Up/Dn/Lt/Rt)

Added Character Set Toolbar (switch with Alt+F1-F12 & Ctrl+F1-F12)

Switched over to VS.NET (using MFC v7.0 now)

Added installer redistributable

Can now load *.ANS, *.ASC from windows explorer

2.0.2 – September 23, 2001

Added ANSI saving/loading

'Halfies' added (F5 - F8)

Bug fixes with multi-user

Only allocates memory for the canvas as needed

80x50 mode support (alt+m to switch)

More aciddraw-ish keys (alt+L for load, alt+S for save, etc)

optimized client/server transfers on initial connect

font.fnt file no longer needed - embedded into .exe

2.0 – 1999

Original prototype version

Crude multi-user support

